FANDOM


Originally by PatrickN. You can download the PDF of this Treatise here :

Please note that specific menus and controls for YS Flight Scenery Editor in this document may be different than the current version. 

IntroductionEdit

I have received requests in the past to make a tutorial for making maps for YSF. I’ve put it off for several months because I have not been very interested. I get a lot of questions, so I’ve decided to start a tutorial, which will likely turn into a lengthy discourse on the subject of map making in YS Flight. In writing this manual I will be starting at the place I start when I decide to make a map: research. A map cannot be started without deciding upon a place to start, and that requires research. I often think of a location that I would like to see in the game, only to find that there is little useful information upon which a map can be based. I’ve been wanting to make a Puerto Rico map since early 2007, but the information available on the various airports is not easy to collect. I approach making a map in the same way I approach writing a history paper: I see what subjects have the prior scholarship and primary sources for me to base my own work on solid information.

Once I decide what map I am going to make, I have to make the map. In this paper I will move in that direction with a chapter on using the scenery editor. There are a lot of tricks I have learned over the years to make a map look good without making the game freeze my laptop. This subject is sure to take a lot of time to write about, since it is where most of the work takes place. The last step of making a map is to actually make the map work in YSF, and then packaging the map for others to share, and that is what my final chapter will discuss.

hope you enjoy reading this, because it is going to be more than just a tutorial. I named this work “A Treatise on the Creation of Maps” because it is much more than just a “how-to” manual for the inner workings of the scenery editor. It includes my philosophies and opinions about how best to create maps using all the tools available, from websites and programs to the 1imagination bestowed upon you by your creator, which you can use to create worlds of your own.

Chapter 1: Researching Your MapEdit

Making a map for YS Flight does not start with learning how to make a map. Before you get to that point you will need to know what your map will look like. Are you making a fictional map, or a map based on a real location on Earth? These are questions that a map maker must ask himself before he starts work on a map. If the map is fiction, then research may not be very important. The fictional-unrealistic map requires nothing more than imagination and very little knowledge of real-world terrain or airport design. The fictional-realistic map requires research. You may not be making a real-world location, but you will want it to look like a place that could exist in reality.

Research for a fictional-realistic or a real-world map should start with airport layouts. Although your map may be of a fictional location, you may still wish to base your airports on real airports. I find that Wikipedia has lists of airports in various US states, as well as other countries. These web articles are good sources for details about runway lengths and widths, and include pictures from the air and ground that will give you an idea about where things should be located in your map. These articles may also include airport diagrams, which will have a simple map of the runways, taxiways, and aprons. These diagrams also have building outlines to represent where buildings are located at the airport. AirNav (www.airnav.com) is alos a good resource for finding detailed information about runway length and width, diagrams, and navigational aids.

Research for a fictional-realistic or a real-world map should start with airport layouts. Although your map may be of a fictional location, you may still wish to base your airports on real airports. I find that Wikipedia has lists of airports in various US states, as well as other countries. These web articles are good sources for details about runway lengths and widths, and include pictures from the air and ground that will give you an idea about where things should be located in your map. These articles may also include airport diagrams, which will have a simple map of the runways, taxiways, and aprons. These diagrams also have building outlines to represent where buildings are located at the airport. AirNav (www.airnav.com) is alos a good resource for finding detailed information about runway length and width, diagrams, and navigational aids.

Another tool that can be useful for mapmaking is YouTube. There is a wide range of videos posted by people from around the world. A search for a video of Honolulu will probably bring up a useful video from a helicopter ride over the city. A search for a video of an air show at NAS Point Mugu will find valuable videos that give snapshots of building layouts and objects in the distance. These videos can be much more helpful than still images because it shows a much more accurate view of the world the video was made in.

Although research is given its own discussion, it is not something that is only done before work begins on the map. Research should continue throughout the mapmaking process. Start by researching the general area and make that part of your map first. When making an island or group of islands, make the islands first with the roads, elevation grids, and city buildings you want. Once the land is made, research each airport and then make each airport one at a time. 2There is no need to get all the reference maps together for all the airports in the beginning. It only makes the job appear tougher to complete. It is easier to keep yourself going if you focus only on what you have done and what you are doing and let what comes next come next, not now.

Chapter 2: Making Your MapEdit

The process of making a map for YSF is probably the reason most readers will have downloaded this paper. As stated earlier, the purpose of this paper is not only to give explanations of how to make a scenery, but to discuss the process in a more philosophical way. After deciding what your map is going to be when it is complete, and after you have collected the initial information about that location, it is time to make your map

Before starting a map, it is important to understand the three basic building blocks of a YSF map. First is the .fld file. The .fld contains the actual scenery you make in the editor. Second is the .stp file. This file contains the locations and detailed information about each start position you place in your map in the editor. A map must have at least one start position. The third file is the sce*.lst file, where * can be anything from “-nery” (stock scenery.lst) to “- _1337”. These three basic building blocks of a YSP maps are essential, as lacking one of them will prevent your map from working.

The first thing to do when you begin making a map is to import a reference background image. I suggest using Google Maps to get a topographic map showing elevations and use that. It is nearly impossible to have realistic elevations in YSF, but you can use this map to draw the polygon to make up the land features, rivers, and placement for major elevation grids.

For making a map in the center of a continent, the easiest thing to do is go to Edit > Set Ground Color and pick a ground color. I find 80, 110, 80 is good for green, and playing around with the R value will get you a more yellow or brown color.

For making islands and coastlines, use “Map > Insert Element > Polygon” and select the color of the ground by clicking the currently selected color in the color box. Go to Edit > Set Ground Color and make that the color you want your water. Island and coastal maps are usually best with the ground color being the water and polygons representing land. Holding the left button and moving the mouse will drag the cursor around the main window. Move it to the border of the coast and press the Enter key to make a point. Follow the coast, making points along the way. If you are making an island, go all the way around until the next point would be where you started. If you are making a coast line next to a large landmass, go up the coast line as far as you want for your map, then make two corners at the extreme top and bottom. Then press the Space Bar and you have the ground.

There are two ways of dealing with water colors around coastlines. In the first option, choose to let the coast meet directly with the primary water color. 0, 40, 80 is a good color for ocean water. In real life, the water closest to a body of land is a lighter color than the deeper ocean. Unselect everything with the “u” key and insert a polygon. Make a lighter area than the main water color (0, 80, 140) that is bigger than the island it surrounds, and then using Edit > Map Priority > Bottom Priority to put it under the island and make it look like it surrounds the island completely. Then, in the same map box, use the “gradation quad strip”, with the second color set to the water color and the first color still set to the lighter water color, to blend the 3lighter water with the darker water for a more realistic look. Check the box for “Close Loop” to go all the way around the island.

To make a beach, select a color like 220, 220, 170 for sand. Using the “Thick Line” option set for 30 meters, insert a line of the sand color around the areas the beach is located right on the edge of the island. The color should be darker for volcanic beaches. Insert a “gradation quad strip” with the second color being the same as the water color immediately next to the cast line (either the main water color or the lighter color if that technique was used). If the beech does not go all the way around the island, uncheck the box for “Close Loop”. This technique will blend the sand color into the water color and make it look like the water level is rising and falling.

Sometimes there are areas where the ground is different colors in different regions. This is especially true in areas where rainy regions meet dry areas, or around rivers and lakes where it is greener closer to the water. Use the same techniques to make those areas stand out. Insert a polygon of the dryer color (110, 115, 80) and use the gradation quad strip to blend it with the greener areas. This type of area can also be found around elevation grids. To make an elevation grid, mark three corners to make it the right shape. It is helpful to adjust the number of grids so they are all close to the same size. After pressing the Space Bar to insert the elevation grid, make sure you press the Esc key so you can begin selecting nodes to raise. Sometimes it is useful to hide all flat faces to make it easier to raise only nodes in places that should be elevated. An example would be around coast lines or rivers that should not be covered by a mountain.

Roads are simple to add using the thick line feature, especially if when using a reference map with highways marked. Unless map is supposed to be super-detailed, stick to the main highways and not worry about smaller streets. 15 meters is about the right width for a road of any kind, although smaller roads can be only 10 meters and interstate highways around major cities can be 20-30 meters. Road colors vary, but something close to 90, 90, 90 is an appropriate color. Rivers can be inserted into the map using the same method. It may be good to start by laying down a strip 50 meters wider than the river in a color close to 80, 130, 80 to represent the greener area around the river. 135, 130, 90 is a good color for muddy lakes and rivers often found inland. Gradation quad strips can be used to make the river delta.

At this point in the process, it is time to go to Map > Convexnize All. This feature optimizes the map’s ability to be processed by YSF and the computer it is running on. Convexnize All can transform a map that drains a computer’s resources into a map that runs smoothly with the best graphics settings turned on. Save the map and close it. Individual airports should be made in their own map file and inserted into the map. There are several reasons for this, but the main reason is that it allows a modular map system that allows individual airports to be removed, replaced, updated, or even exported for use in a new map.

This chapter was written to give a general idea of how to start making a map. From learning the parts of a map to learning how to use the different features of the scenery editor, there are many things to understand before a map can be produced. With that out of the way, and the map well on its way, the next step is to build the actual airports that will be the focus of the map while planes are still on the ground.


Elevation grids can be used to make buildings rather than using ground objects. Several mapmakers have stated their belief that elevation grid buildings cause less lag than ground objects. To make a flat-top building using elevation grids, first place an elevation grid with 0 grids in x and 0 grids in z. Set the three coordinates and press the Space Bar. Press the "Esc" key to clear the menu and select all four corners (nodes). Click the menu for ElevationGrid -> Move 4Node. In the Coordinate box, enter the height in meters that you want your building in the middle box, or pull the green icon in the center of the elevation grid with your mouse. Press the Space Bar. At this point there is a flat surface "floating" in the air. Go to the menu for ElevationGrid -> Show/Hide Side Wall and click all four check boxes. Colors can also be changed for each side.


To make a building with a sloped roof, make an elevation grid with 2 grids in x and 0 grids in z. If you want a building with a series of slopes (^^^), enter more grids, even numbers each time, in the x. The outside nodes (left and right, front and back) will be raised, but the middle nodes (front and back) will be raised higher. If you are using a series of slops, every other set of nodes will be raised to the height of the outside nodes, and the remaining will be raised higher to give the desired effect. Show all four sides just as you did in the flat-top building.

Chapter 3: Making Your AirportsEdit

Making a good airport for YSF starts with making good runways. This is where Google Maps becomes really useful. You can zoom in enough to get a view of the number of lines on the runway, as well as other markings such as numbers, landing lines, locations of arrows, taxi lines, building locations, and the general layout of the airport. This is important because the satellite photos are often more up to date than some of the diagrams available online! Making a runway starts with inserting a thick line the width of the runway. That can be anything from about 23 meters up. This is where AirNav is going to be useful because it provides length and width in standard as well as metric units.

When airport is complete, buildings should be added. Unless custom ground objects are made for the map, it is not easy to make a 100% realistic building layout. A combination of ground objects and elevation grids can make a nice look to an airport, though. It is probably best not to try to make every single building, since the more buildings, whether they are ground objects or elevation grids, the slower the map will run. The objects you place in and around your airport may also include ILS boxes, VOR arrays, and NDB towers. VOR and NDB objects are easy to place. Just insert the ground objects wherever they should be. For added realism, rotate the NDB tower to its real-world angle. The VOR array is round, so that won’t really make much difference. The ILS box is a different story. The box has to be positioned 50m from the center of the runway on the right side of the runway when facing it on landing. Once that is done, it has to be properly rotated so that the ILS signal is lined up with the center line of the runway. Names should be provided for the ILS, VOR, or NDB. The ILS should have a short airport name along with the runway number that it represents. To give these objects names, go to GroundObject -> Set ID and Tag. A box will appear for the name to be entered.


Another addition to a map may be an F9 view point. These are rectangular regions that should be small and allow players to press F9 and get a view of various aircraft flying near the view point’s location in the map. Go to Edit -> Insert -> Rectangular Region, and a box will pop up. Select 10:View Point. Enter three points around the spot where the view point should be placed and click the Space Bar. These can be placed in open areas where buildings do not obstruct the view of runways, or they can be placed inside certain control towers. To simulate someone standing on the ground watching an air show, it should be moved to an elevation of about 10m. To move the view point, go the menu and click Select -> Select Item. The view point will appear to be a red box, so click the red box to select it. Go to Edit -> Move -> Current Item. In the Coordinate Box that appears, the second box from the top is the vertical entry. 5Enter the number “10” in that box and click the Set button. Click the top of the scenery editor window and press the Space Bar. The average person is shorter than 2 meters, but in YSF the view point needs to be at about 10m to give a clear view of aircraft on the ground and in the sky because short aircraft can cause viewing problems at more realistic heights.

Chapter 4: Making Your Map WorkEdit

Another addition to a map may be an F9 view point. These are rectangular regions that should be small and allow players to press F9 and get a view of various aircraft flying near the view point’s location in the map. Go to Edit -> Insert -> Rectangular Region, and a box will pop up. Select 10:View Point. Enter three points around the spot where the view point should be placed and click the Space Bar. These can be placed in open areas where buildings do not obstruct the view of runways, or they can be placed inside certain control towers. To simulate someone standing on the ground watching an air show, it should be moved to an elevation of about 10m. To move the view point, go the menu and click Select -> Select Item. The view point will appear to be a red box, so click the red box to select it. Go to Edit -> Move -> Current Item. In the Coordinate Box that appears, the second box from the top is the vertical entry. 5Enter the number “10” in that box and click the Set button. Click the top of the scenery editor window and press the Space Bar. The average person is shorter than 2 meters, but in YSF the view point needs to be at about 10m to give a clear view of aircraft on the ground and in the sky because short aircraft can cause viewing problems at more realistic heights.

In the scenery folder, add a new text file named sce*. This file must start with the letters “sce” or it will not work. When saving this file, the type should be set to “all” and the file type extension “.lst” should be at the end of its name. An example might be “scenery_frankfurt.lst.” The case of this file name will not matter. The case of the text inside the file is that which must be consistent with actual file names. To create that text, the starting point is always a unique name for the map that has just been created. If the map is a new map of Hawaii, Chicago, or Fiji, be aware that giving it such a name may cause unintended complications due to the existence of maps with those names. Adding an ID tag of some kind will allow the YSF program to distinguish between maps. An example would be “Hawaii[PMNV]” or “[PMNV]Malta.” Spaces will not work in YSF names, so use an “_” or “-“ to represent those spaces. After giving the map a title, a space is used to indicate a break between the title and the location of the scenery file. This use of a space to indicate such a break is the reason for not being able to use a space in the title. “Hawaii PMNV” would be recognized as Hawaii being the name, but PMNV would be the location, and would not lead to a real file, so there would be an error.

The next step of creating the .lst file is to name the location of the scenery file. If the file is named “FRANKFURT.fld” and is located in a folder named “neocon” which is located in the “user” folder of YSF, the text after the space would be “user/neocon/FRANKFURT.fld”. Once again, this segment should be followed with a space. The final step is to name the location of the start position file, which should be named “FRANKFURT.stp”. This location would be “user/neocon/FRANKFURT.stp”. The complete line would be “Frankfurt[PMNV] user/neocon/ FRANKFURT.fld user/neocon/FRANKFURT.stp”.

At this point the map is read to use, but it is of great importance that the next step be to actually test the map in YSF. Too many releases had major problems because new modders 6released work that had never been tested in the game. A lot of embarrassment and harsh words could have easily been saved had the modder only taken the time to open up YSF and fly around for a few minutes. Land at or take off from each airport to make sure the ground is paved and the ground objects and markings are showing up. This is the point where all the problems can be located and corrected before anyone has to know they ever existed. If there are problems, and they can’t be fixed, search for answers on YSP. If, after an extensive search, the problems remain uncorrected, consider posting a request for help in the addon creation section.


Some modders may consider their work complete, and all that s left is to compress their files into a .zip file and post them to the web for the world to enjoy. There are a few ways to make that process better for everyone. Start with one empty text file and insert into said file a description of the project. What is the map? Is it real or imaginary? Are there any start positions on the ground or in the air? What airports are there? Are there realistic nav aids such as VOR and ILS? These are all important characteristics that uses will want to know before downloading the map, and this information can also make up the body of the release post on YSP.

Another piece of information that should be included with each release is the details of how others may use it. There have been all kinds of “terms of use” included with releases. Some have been restrictive to the point of absurdity, while others are as close to public domain as can be. YSF is a free game, and charging for addons will bring angry comments and a storm of criticism, not to mention the fact that they will not be downloaded by anyone. On the other hand, a modder’s work is their intellectual property and they can decide for themselves how it should be transferred and what modifications the users can make. Some modders have strict restrictions such as “do not release any modifications,” but I have found that the truly great modders of YSF understand that the goal is to reach a more perfect addon, not to enlarge their egos. It is reasonable, however, to ask other modders to get permission before releasing modifications.

One thing that should never be done is to place a demand on how the addon should be used by the person who has downloaded it, or place upon them an unjust burden. For example, the consumer should be expected to be a total idiot who can just barely operate a computer. This is rule number 1 of public speaking because the speaker must always avoid uncommon language that some members of the audience may not understand, resulting in the audience tuning out. The same is true of addons for YSF. If users cannot figure out how to install the addon easily, they will likely give up and the hard work that went into its production will go to waste.

To package the addon, start by creating on the desktop folders named “scenery,” “user,” and the name of the unique folder in the user category. Copy the .lst file from the YSF scenery folder to the scenery folder on the desktop. Copy the .fld and .stp files into the appropriate, uniquely-named folder on the desktop, and then move that into the user folder on the desktop. Copy the text file with the description of the addon (README FRANKFURT, for example) to the desktop. Highlight the scenery and user folders and the text file, right click, and compress to a zip file using “Send to -> Compressed File” or whatever program for doing so you may have installed.

The addon is packaged and ready to send to the world. The methods of releasing the addon are great in quantity, but not always in quality. There are file sharing sites that can be used, but most of them do not allow direct linking and they often require several clicks followed by or preceding a countdown from as little as five seconds to as much as 30 or even 60 seconds. This is a demand that is sure to turn off consumption and increase hostility. A simple, free 7website provided by a service such as Google will allow addons to be presented in an organized and creative way while also allowing direct links to downloads on forums or from the modder’s web page. Google Sites also allows users to track modifications and updated versions.

Conclusions:Edit

This document is meant as a way for the reader to not only understand the workings of the YSF Scenery Editor and how to make a map, but to also give the reader an understanding of why I do things the way I do them. I have a system that works very well for me. Others are sure to find may areas of this treatise in which they disagree with me. That is ok, because each human is born with a mind of their own with which they must make their own discoveries and reach their own conclusions. My philosophies of making maps are outlined in the body of this document for everyone to read, absorb, digest, and spit out in their own terms. The most important thing that I hope you understand is that making good maps does not start at the beginning, and it doesn’t come from reading tutorials. It comes from practice, experience, and a never-ending quest for the unobtainable goal of perfection. The ultimate goal that accompanies the making of maps should be fun. Have fun, make maps, and share your talents with the world.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.