FANDOM


Tutorial by waspe414. Originally posted on YSFHQ.com on May 6th, 2011.

Note that the drop down menu paths will differ if you are using the test version of scenery editor (20130519 or later)

IntroductionEdit

If you are unfamilar with Scenery Editor and the map making process, read this first: viewtopic.php?f=40&t=1578

If the map has few enough elements, it is possible to do this without exporting things as seperate files, but once a scenery has more than three of four of anything, it is very difficult to tell the difference.

Always make a backup copy of the map before doing this. You don't want to lose anything.

Terms:

  • Scenery, Field, of .fld: The map file.
  • Child Scenery, or .pc2: the segments of the scenery. NOTE: When importing, the program calls this a map.
  • New Scenery: The file to be edited in Notepad (or equivilent simple text editor), the .fld with the exported .pc2 in it.
  • Original Scenery: The whole scenery that the final edit will be put back into.
  • Scenedit: Scenery Editor
  • RGB: Red Green Blue colour code, using numbers between 255 and 0 (looks like 255 255 255 or 10 54 187 in code). What Scenedit uses to designate colour for items.

3D Rotation:Edit

Rotation in the vertical direction is something the Scenery Editor simply can not do. It is, however, accomplishable by using Notepad.

Before you begin the process you must make sure that everything you want rotated is in its own child scenery (pink box).

  1. Select the child scenery you want rotated vertically.
  2. Export it as a .pc2 file. (File > Export > Current Item)
  3. Delete the item from the original scenery and save.
  4. Close and reopen Scenedit. This cleas the default save name. (Not doing it can cause you to accidentally overwrite your original scenery File.)
  5. Create a new map and import your .pc2. (File > Import > Map)
  6. Place it, then rotate it horixontally by the amout you want it rotated vertically. If you want it to be straight up and down, rotate it 90 degrees. (NOTE: Watch out for positive and negative angles. Generally you want to rotate it positively, and it can get inverted if you mess it up...)
  7. Save the current scenery as a different file name than your original scenery. (File > Save As)
  8. Open the new .fld in Notepad (or comperable program). You will see something like this:
Image8b



PC2
FIL "00000001.pc2"
POS -300.00 -0.00 100.00 0.00 16384.00 -0.00
ID 0
END

Indicates it's a child scenery.
Tells the program which of the sections above it in the file to look at.
Position in meters. Horizontal, vertical, horizontal.Yaw angle (standard rotate). Pitch (The one you want to change it to). Roll (Used if pitch is rotating it about the wrong axis).
Not a clue.
Ends the .pc2 segment.


You want to move the value from yaw to either pitch (normally what works for me) or roll.



  1. Save the Notepad file, and open it in Scenedit to make sure you did it right.
  2. Open the original scenery, and import the new scenery (File > Import > Scenery)
  3. Move and rotate the new scenery, now inside the original scenery, and around normally if neccessary. (Edit > Move > Current Scenery)

Colouring Elevation Grids (.ter):

This allows each face of an elevation grid to be it's own color, rather than all being the same.
  1. Insert your elevation grid normally and with whatever base colour you wish.
  2. If you are doing this to an older map, unhide all faces to be sure. (Elevation Grid > Unhide > All Faces)
  3. Select the faces you want to colour a single colour (so if you have two colours and the base you need to do this twice).
  4. Hide these faces. (Elevation Grid > Hide > Current Faces)
  5. Export the elevation grid. (File > Export > Current Item)
  6. Open the .ter file in Notepad. You will see many lines similar to this:
BLO 0.00 R 1 0 127 0 0 0 127 0
Meaning:
Part of the grid
Height(m)
Visible
Colour
Invisible
  1. There are two wats to do the following: Either manually in Notepad, or with the Find/Replace feature in something like Microsoft Word.
  2. Copy and Paste the entire file into your word processor. Find "0 (colour RGB text here)" and replace it with "1 (New colour RGB text here)" For Example: "0 0 127 0" to "1 255 127 110"
  3. Copy and paste the entire file back out of your word processor and into Notepad. Save.
  4. Open with Scenedit to make sure it's correct. Repeat if neccessary for other colours.

 

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.